Booking.com Reservations Delivery Issue

Incident Report for Rentals United

Resolved

Booking.com has resolved the technical issue affecting their reservation endpoint.
Posted Jan 30, 2026 - 16:42 UTC

Monitoring

Reference: https://connect.booking.com/status/incident/595

Description: Booking.com is currently experiencing a technical issue with their reservation API endpoint. As a result, new reservations made on Booking.com are not reaching Rentals United.

Impact:
New bookings, bookings modifications, cancellations are not delivered to Rentals United systems.
No action is required from your side; this issue is strictly on the Booking.com side.

Resolution: As soon as Booking.com resolves the incident, Rentals United will automatically pull all pending bookings and sync calendars.
Posted Jan 30, 2026 - 13:46 UTC
This incident affected: Sales Channel Integrations (Booking.com).