Phishing attempt identified
Incident Report for Rentals United
Postmortem
Posted Oct 07, 2021 - 10:59 UTC

Resolved
We have noticed that some of our customers received phishing emails from an unknown party.
These emails included a link to a page very similar to the Rentals United login page hosted on a URL very similar to Rentals United. That page is designed to intercept your Rentals United login and password. Once you enter your credentials, you are taken to the real rentalsunited.com page and need to log in again.
By this, the criminal gets your Rentals United login and password.

Please read about Phishing tactics here : https://en.wikipedia.org/wiki/Phishing


In order to strengthen the security of Rentals United accounts and to prevent the criminals from entering accounts we have enabled multi-factor authentication for all Rentals United accounts. Up until now, Multi Factor Authentication was optional in Rentals United.

Multi-Factor Authentication (MFA) is an authentication method where a user is granted access only after successfully confirming the log-in attempt. In Rentals United, Multi-Factor Authentication is implemented via the confirmation email configured in the Rentals United Company Profile.

Users be prompted to confirm login attempt by clicking a link sent to a notification email address.

Once user clicks the link, they will be logged into Rentals United

In case the link is clicked after the 15 minutes is passed, users will be notified that the link has expired.
Then, the log-in credentials (username and password) must be provided again

Please note that this is only related to Rentals United User Interface via web browser. No API connections are affected.

In case of questions please contact you Account Manager or Rentals United Support Team via https://new.rentalsunited.com/support

// Additional comments //
As you could read in the Wikipedia article linked above, phishing attacks are one of the most popular internet crimes. Rentals United has no control over it and can only act to prevent negative effects. Make sure you always check the identity of the websites you provide your credentials to.
Posted Oct 06, 2021 - 14:00 UTC